platformOS Community

How do I fix a deploy issue?

SR Jan 24 2021 at 16:16

When I deploy, I receive the following error...

Error: EPERM: operation not permitted, open...

I am able to sync, and there are no log errors. And, I was able to deploy this instance previously.

I tried re-adding the staging environment, but that also didn't solve the issue.

Any suggestions?

  • Adam Jan 24 2021 at 16:23
    @pawel or @piotr may have hints.
  • JJBragg Jan 25 2021 at 15:04
    Hey Scott... maybe a local permission issue?
  • SR Jan 25 2021 at 15:32
    Thanks for the replies. It's working today - although I'm not sure why (I didn't make any changes).
Pawel Jan 26 2021 at 12:14

Looks like windows/npm issue:
Someone fixed it by disabling defender's real time protection:

From Microsoft blog:

Permissions is hard to debug, might be an updated node version without proper access rights to the directory (for npm).

  • SR Jan 28 2021 at 19:47
    Thanks @Pawel - if it happens again I'll try this.
Please sign in or fill up your profile to answer a question